WordPress Otomatik Tema ve Eklenti Güncellemeleri Nasıl Kapatılır

WordPress in, eklenti ve temaların güncellemeleri bazen can sıkıcı olabiliyor. Bu yüzden güncellemeleri kapatmak isteyebilirsiniz. Açıkçası güncellemeleri güvenlik açısından kapatmanızı pek tavsiye etmiyoruz. Güncellemelerin nasıl kapatılacağını kod bilgisi olan arkadaşlar için açıklamaya çalıştık.

Kod bilgisi olmayan arkadaşlar da anlatım sonunda bulunan eklentiyi wordpress sitesine kurarak eklenti yardımı ile otomatik güncellemeleri kapatabilirler. Düzenlemeleri yapmadan önce düzenleme yapılacak dosyaların yedeklemenmesi tavsiye edilir.

FTP ana dizinde bulunan wp-config.php dosyasını Notepad++ ile açın. Notepad++ ekranında

[php] <?php [/php]

kodundan hemen sonraya

[php]
define( ‘WP_AUTO_UPDATE_CORE’, false );
[/php]

kodunu ekleyin. Böylece WordPressin otomatik güncellemeleri kapatmış olacaksınız. Bundan sonra düzenlemeleri kaydedin ve dosyayı FTP sunucunuza tekrar yükleyin.

Eklenti ve temalarda da güncellemeler aşağıdaki gibi kapatılmaktadır.

Eklenti güncellemelerini kapatmak için :

[php]
add_filter( ‘auto_update_plugin’, ‘__return_false’ ); [/php]

Tema güncellemelerini kapatmak için ise:

[php]
add_filter( ‘auto_update_theme’, ‘__return_false’ ); [/php]

Kodlarını wp-config.php dosyanızın içine atınız.

Ben bu şekilde kodlarla yapamam diyorsanız, Easy Update Manager eklentisini kurarak da güncellemeleri kapatabilirsiniz.


Bunlar da İlginizi Çekebilir
WordPress Tema Kodlama Eğitimi Ücretsiz

Bu sayfada ücretsiz tema Kodlama eğitimini paylaşacağız. Bunun için html bir şablonu kullanacağız. Sırayla eğitimler tek tek eklenecektir.   Ders 1: WordPress Temasını Tanıyalım  

WordPress Yönetim Paneli Footer Alanındaki Versiyon Bilgisini Kaldırmak

WordPress sitenizdeki footer kısmında yer alan versiyon bilgisini gizlemek isteyebilirsiniz. Bunun için iki kod paylaşacağım. Birinci kod Yönetici dahil tüm kullanıcılardan kaldırıyor. İkinci kod ise yönetici hariç diğer kullanıcılardan kaldırıyor. 1. Kod: Yönetici dahil tüm kullanıcılardan kaldırır. function my_footer_shh() { remove_filter( ‘update_footer’, ‘core_update_footer’ ); } add_action( ‘admin_menu’, ‘my_footer_shh’ ); 2. Kod: Yönetici hariç diğer kullanıcılardan […]

Warning: Cannot modify header information – headers already sent by output started at pluggable.php on line 945 Hatasının Kesin Çözümü

WordPres Sitemde ön uç profil sayfası hazırlarken şifre değiştirirkrn aşağıdaki hatayı veriyordu. Şifre değişiyor fakat hata bir türlü düzelmiyordu.

Yorum Yok
Yazımız ile ilgili fikirlerinizi paylaşırsanız mutlu oluruz.

+ 28 = 36